Financials are taking longer to post to claims than expected

Incident Report for Candid Health

Resolved

This incident has been resolved. A forward fix was implemented and the financials on previously reported claims have been posted successfully. We are back to our normal processing times.
Posted Mar 18, 2026 - 01:12 PDT

Update

We are experiencing delays due to errors in our ERA processing. We have identified the issue and have implemented a fix, and will notify here when all financials are caught up.
Posted Mar 17, 2026 - 07:26 PDT

Investigating

We are experiencing delays due to errors in our ERA processing. We have identified the issue and have implemented a fix, and will notify here when all financials are caught up.
Posted Mar 17, 2026 - 07:22 PDT
This incident affected: ERA processing pipeline.