Reports having issues loading

Incident Report for Candid Health

Resolved

Affected reports should be operational again.
Posted Jul 08, 2026 - 14:30 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 08, 2026 - 13:09 PDT

Monitoring

Certain reports are having errors loading. We have identified the issue and a fix will be rolled out shortly
Posted Jul 08, 2026 - 13:09 PDT
This incident affected: Reports.