Delays in processing rejection signal from clearinghouse and payer

Incident Report for Candid Health

Resolved

Payer rejections and acceptance responses are now up to date for all claims.
Posted Aug 20, 2025 - 09:21 PDT

Identified

Some payer rejection or acceptance responses are delayed in being visible on submitted claims. Candid is working to ensure all received payer responses are recorded on claims in a timely manner. This issue only affects some claims submitted in the past 7 days.
Posted Aug 14, 2025 - 15:59 PDT
This incident affected: Claim Submission.