Issues updating patient data and adding tags

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted May 14, 2026 - 09:50 PDT

Update

We are continuing to monitor for any further issues.
Posted May 14, 2026 - 09:50 PDT

Monitoring

A fix has been implemented. Please hard refresh to get the most up to date version of the app.
Posted May 14, 2026 - 06:45 PDT

Identified

We have identified an issue with adding notes to patients and updating tags.
Posted May 14, 2026 - 06:23 PDT
This incident affected: App.