Remits page is not loading

Incident Report for Candid Health

Resolved

We have fixed the issue. This page is fully functional again.
Posted Sep 02, 2026 - 19:01 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2026 - 17:42 PDT

Investigating

The remits page currently is failing to load consistently. We are currently investigating this issue.
Posted Sep 02, 2026 - 17:31 PDT
This incident affected: ERA processing pipeline.