Queue filters/columns not holding after a claim is clicked

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 07:28 PDT

Investigating

We are experiencing issues with filters in queues not applying as expected. Our team is currently investigating
Posted Jul 20, 2026 - 07:04 PDT
This incident affected: App.