AWS Availity Claim Submission Delay

Incident Report for Candid Health

Resolved

Claim submissions have started receiving payer acknowledgements and Availity has acknowledged the backlog of claims submitted on 10/20.
Posted Oct 20, 2025 - 19:20 PDT

Monitoring

Availity is experiencing claim processing delays on October 20th since 3am due to the AWS outage. We are monitoring Availity submission status and will update when normal claim processing resumes.
Posted Oct 20, 2025 - 14:24 PDT
This incident affected: Claim Submission.