Degraded Application Performance

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 10:09 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 06:53 PDT

Investigating

We are experiencing outages on several parts of the platform and are actively investigating
Posted Oct 21, 2025 - 06:35 PDT
This incident affected: App.