"Something went wrong" error message on claim page

Incident Report for Candid Health

Resolved

We have not received any further reports of issues and are marking this incident as resolved.
Posted Aug 21, 2025 - 07:02 PDT

Monitoring

The fix has been deployed. If you still see the "Something went wrong" error message, please refresh your browser or reload the page.
Posted Aug 21, 2025 - 06:26 PDT

Identified

We have identified the root cause issue and are deploying a fix.
Posted Aug 21, 2025 - 06:23 PDT

Investigating

A "Something went wrong" error message is appearing beneath the Non-Insurance Payers section of the claim page for some users. We are actively investigating.
Posted Aug 21, 2025 - 06:05 PDT
This incident affected: App.