Contracts page intermittent outages

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted Sep 17, 2025 - 14:01 PDT

Identified

We have identified an issue causing outages on the Contracts page. We have discovered the root cause and are in the process of actively remediating the issue.
Posted Sep 17, 2025 - 13:14 PDT
This incident affected: App.