App performance degradation

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 07:27 PDT

Monitoring

App performance appears to have returned to normal for most users. We are monitoring for further signs of degradation.
Posted Jul 16, 2026 - 06:57 PDT

Investigating

We have received some reports that the app is functioning slower than usual. We are investigating.
Posted Jul 16, 2026 - 06:17 PDT
This incident affected: App.