Claim action and submission performance degradation

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 15:54 PDT

Monitoring

We have received reports and confirmed intermittent occurrences of performance degradation on claim actions and submissions. We have identified the core issue, and remediation is currently in flight
Posted Sep 15, 2025 - 11:26 PDT
This incident affected: App and Claim Submission.