Reporting Issues

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 12:15 PDT

Identified

All reports are experiencing significant lag. We have identified the issue and expect to remediate within an hour.
Posted Jul 29, 2025 - 11:24 PDT
This incident affected: Reports.