Bulk action and claim submission slowness

Incident Report for Candid Health

Resolved

This incident has been resolved and all bulk actions and claim submissions should now be caught up.
Posted Feb 03, 2026 - 10:06 PST

Identified

Bulk actions and claim submissions are currently taking longer than usual. We are actively monitoring and speeding up processing to get all queued actions completed and will keep this thread updated as progress is made.
Posted Feb 03, 2026 - 08:26 PST
This incident affected: App.