Claim Submission taking longer than usual

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 19:32 PST

Identified

We've identified an issue causing claim submission to take longer than normal. We are implementing a fix for this behavior.
Posted Nov 12, 2025 - 10:32 PST
This incident affected: Claim Submission.