General App/API Slowness

Incident Report for Candid Health

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 09:51 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 10, 2025 - 09:39 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 10, 2025 - 09:24 PDT

Investigating

We are tracking degraded performance of some API endpoints which is also affecting app performance & responsiveness. We are actively investigating this issue.
Posted Oct 10, 2025 - 08:57 PDT
This incident affected: API (Encounters & Coded Encounters APIs, Change Healthcare Eligibility API, Availity Eligibility API) and App.