Longer claim submission wait times

Incident Report for Candid Health

Resolved

All delays in claim submission have been resolved. Claim submission should be operating normally.
Posted Oct 29, 2025 - 11:31 PDT

Monitoring

Our system throughput has improved and will update here when all systems are caught up.
Posted Oct 29, 2025 - 08:38 PDT

Investigating

We are experiencing an unusually high volume of claim submissions which may cause new submissions to take longer than normal. We are adding system resources to work through the backlog and bring down submission times.
Posted Oct 29, 2025 - 04:58 PDT
This incident affected: Claim Submission.